Invoice Search Slowness
Incident Report for Taulia, Inc.
Resolved
This incident has been resolved.
Posted 5 months ago. May 09, 2019 - 17:28 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 5 months ago. May 09, 2019 - 15:56 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted 5 months ago. May 09, 2019 - 15:56 UTC
This incident affected: North America (Web Portal).