SSO Login failures for multiple buyers and suppliers

Incident Report for Taulia, Inc.

Resolved

This incident has been resolved.
Posted Jun 09, 2026 - 00:36 UTC

Investigating

SSO is failing for multiple Buyers/Suppliers with a message "System Error"
We are currently investigating the issue.
Posted Jun 08, 2026 - 21:25 UTC
This incident affected: North America (Web Portal) and Europe (Web Portal).