Taulia support website (support.taulia.com) is not loading
Incident Report for Taulia, Inc.
Resolved
This incident has been resolved.
Posted 5 months ago. May 10, 2019 - 16:08 UTC
Identified
We have identified an issue that is preventing some users from accessing support.taulia.com. We are actively working on resolving the issue. If you need to contact support, please use the phone numbers below:

US Support Number: 1 415-942-8173
US Toll-Free Support Number: 1-866-913-8409
Mexico: +52 55 8526 8353
France: +33 9 87 67 15 07
Brazil: +55 19 3957-3424
El Salvador: +503 2113 8988
Peru: +51 1 7089796
Germany: +4921195987913
UK: +44 1302 231188
Spain: +34 518 88 06 16
Poland: +48 58 319 17 24
Ireland: +353 76 680 5382
Singapore: +65 3138 9422
Australia: +61 3 9070 5477
Sweden: +46 8 580 976 42
South Africa: +27 87 551 7187
Posted 5 months ago. May 08, 2019 - 13:14 UTC