Performance Degradation due to Cloud Provider issues

Incident Report for Taulia, Inc.

Resolved

This incident has been resolved.
Posted Jun 13, 2025 - 01:45 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 12, 2025 - 23:24 UTC

Investigating

Our cloud provider has identified issues with several of their products and services, which are currently impacting Taulia platform services. Taulia Operations teams are on alert and monitoring the situation.
Posted Jun 12, 2025 - 19:31 UTC
This incident affected: North America (Web Portal, XMLRPC, AnyERP, eFile/eSend, Analytics), Europe (Web Portal, XMLRPC, AnyERP, eFile/eSend, Analytics), and QA7 (UAT/Staging) (Web Portal, XMLRPC, AnyERP, eFile/eSend, Analytics).